Upgrading to 3.0.1

Anyone else here had issues upgrading?
We update to 2.123 and it immediately told us (on the front end) to update to 3.0.1 - however when we try and do that it just says we have the latest version already...
I've logged a ticket with support but wondered if anyone else had found this an issue?

I made an image of my Production system, and just ran the upgrade script. It went through, no issues, and took me all the way to 3.0.1. I thought GREAT, this is wonderful. Of course the image has a different IP, different host name, and I made sure the config file entries match the new URL for this test machine.

I let it soak for a few days, and then I ran it on my identical production system. (Again, the only differences are the IP , host name, and domains and base_domain lines in docker.env).

It only upgraded me to 2.117.21

Both the TEST and PROD were on 2.116.9. This was the version we installed for our trial, and had not upgraded.

The TEST machine went all the way to 3.0.1.

The prod is stuck at 2.117.21.

There are no differences in the other files within the retool directory where all of the installer files are (which is where the docker.env and docker-compose.yml are housed)

If anyone else has any good ideas, I'm game as I cannot figure this on out. It doesn't make sense to me.

I found a solution to this, but it does not explain why. On the 'SANDBOX' version (what I am calling test), there is both a Dockerfile and a Dockerfile.local. Both files are identical. The retool line is:

FROM tryretool/backend:latest

On the 'SANDBOX' version, it upgrades all the way to 3.0.1. On the Production version, it did not. I edited the Dockerfile and told it to go to 2.123.12 and it did not work. I edited the Dockerfile.local, and did the same thing. This time... it Upgraded to 2.123.12.

So I edited the Dockerfile.local again with 3.0.1 for the version, and voilla... I'm at 3.0.1.

Why does it work on one server, but not the other to leave it at latest?

Which file should it be referencing? Dockerfile or Dockerfile.local? (Even though they are identical).

I would suggest editing your Dockerfile.local and changing
FROM tryretool/backend:latest
FROM tryretool/backend:3.0.1

I'm betting that will take care of your upgrade issue.

1 Like

Hi @summitrad - yeah I already tried using both latest and the version number, neither seemed to work for me... bit stumped.
Since it's been the weekend, I might try again today and see what happens...

Are you using the supplier postgres database in docker or an external database?
If the instances use the same database, then the update of the first instance will also apply the required changes to the database. Maybe that that is causing an issue?

I've upgraded last week from 2.123 to 3.01 without any issues. My database is external.

1 Like

Something must've happend on Retool's end over the weekend - re-ran with latest today and it's updated us to 3.0.3 now...

Thanks all for your input and advice :slight_smile: