Self-Hosted Retool Suddenly Stopped Working (SequelizeHostNotFoundError)

Hello! I am just getting familiar with Retool and its self-hosted variant. It was working for the past two weeks on my local machine. But yesterday, a docker-compose down then docker-compose up seems to have fouled things up. Now, docker-compose up fails to start Retool. Here are the error messages:

docker-compose up
[+] Running 9/9
 ⠿ Network retool-onpremise_db-ssh-connector-network  Created                                                                          0.0s
 ⠿ Network retool-onpremise_backend-network           Created                                                                          0.0s
 ⠿ Network retool-onpremise_db-connector-network      Created                                                                          0.0s
 ⠿ Network retool-onpremise_frontend-network          Created                                                                          0.0s
 ⠿ Container retool-onpremise-postgres-1              Created                                                                          0.1s
 ⠿ Container retool-onpremise-db-ssh-connector-1      Created                                                                          0.1s
 ⠿ Container retool-onpremise-db-connector-1          Created                                                                          0.1s
 ⠿ Container retool-onpremise-jobs-runner-1           Created                                                                          0.1s
 ⠿ Container retool-onpremise-api-1                   Created                                                                          0.1s
Attaching to retool-onpremise-api-1, retool-onpremise-db-connector-1, retool-onpremise-db-ssh-connector-1, retool-onpremise-jobs-runner-1, retool-onpremise-postgres-1
retool-onpremise-db-ssh-connector-1  | [deprecated] do nothing.
retool-onpremise-postgres-1          | LOG:  database system was shut down at 2022-06-30 19:40:33 UTC
retool-onpremise-postgres-1          | LOG:  MultiXact member wraparound protections are now enabled
retool-onpremise-postgres-1          | LOG:  database system is ready to accept connections
retool-onpremise-postgres-1          | LOG:  autovacuum launcher started
retool-onpremise-db-connector-1      | [process service types] DB_CONNECTOR
retool-onpremise-db-ssh-connector-1  | [process service types] DB_SSH_CONNECTOR
retool-onpremise-jobs-runner-1       | waiting 15 seconds for postgres:5432
retool-onpremise-postgres-1          | LOG:  incomplete startup packet
retool-onpremise-jobs-runner-1       | postgres:5432 is available after 0 seconds
retool-onpremise-jobs-runner-1       | not untarring the bundle
retool-onpremise-api-1               | waiting 15 seconds for postgres:5432
retool-onpremise-postgres-1          | LOG:  incomplete startup packet
retool-onpremise-api-1               | postgres:5432 is available after 0 seconds
retool-onpremise-api-1               | not untarring the bundle
retool-onpremise-db-connector-1      | Database migrations are up to date.
retool-onpremise-db-ssh-connector-1  | Failing checking database migrations
retool-onpremise-db-ssh-connector-1  |
retool-onpremise-db-ssh-connector-1  | ---------------------------
retool-onpremise-db-ssh-connector-1  | -     EXITING RETOOL      -
retool-onpremise-db-ssh-connector-1  | ---------------------------
retool-onpremise-db-ssh-connector-1  |
retool-onpremise-db-ssh-connector-1  | Error running database migrations: SequelizeHostNotFoundError: getaddrinfo ENOTFOUND postgres
retool-onpremise-jobs-runner-1       | [process service types] JOBS_RUNNER
retool-onpremise-db-ssh-connector-1 exited with code 1

I can't seem to figure out why it now cannot find its own postgres. There is no other more verbose version of the error. I hadn't changed the Dockerfile or docker-compose.yml before this started happening. I wouldn't be surprised if I did something wrong, but I don't have a guess as to what I did.

Update: moving my previous retool out of the ~/retool/retool-onpremise dir, deleting those dirs, and doing a fresh install of /bin/bash -c "$(curl -fsSL" < <(echo "LICENSE_KEY") seems to have fixed this today.

Hey this command for a fresh install is outdated (pointing to the ssop branch).
If you're doing a fresh install, please follow the docs instead:

I.e., use the updated URL for the easy install script:

/bin/bash -c "$(curl -fsSL"

Also, if your previous installation was older, you probably have to manually remove the previous docker volumes of your retool postgres db. Warning: this will delete your previous retool data as well.

1 Like