Tableau integration overrides :jsdebug=n parameter and always shows "debug render mode"

Embedding Tableau in Retool via the tableau component will always show "debug render mode" within the embedded dashboard.

According to this solution, the workaround is to append :jsdebug=n to the URL.

Unfortunately, this does not work: The Retool tableau component will always append another :jsdebug=y parameter, which overrides any such parameter that the retool editor adds.


I put in the URL

Retool converts this to,1&:embed=y&:showVizHome=n&:jsdebug=y&:bootstrapWhenNotified=y&:apiID=host0

Which now contains both jsdebug=n as well as jsdebug=y.

Furthermore, it forces a :size=1527,1 parameter. For my own dashboards, I'd like to avoid this as well, as the ,1 suffix will trigger a mobile phone layout.

Hello @michael_h,

Welcome to the forum!

To disable the debug render mode in the Tableau component in Retool, you can try the following workaround:

  1. Open the Tableau dashboard in your web browser and append ?:jsdebug=n to the URL.
  2. Copy the full URL from your web browser's address bar.
  3. In Retool, open the Tableau component's properties and paste the copied URL into the "Url" field.
  4. Append &:jsdebug=n to the end of the URL in the Retool Tableau component's "Url" field.

So, your final URL in the Retool Tableau component should look like this:,1&:embed=y&:showVizHome=n&:jsdebug=n

By appending &:jsdebug=n at the end of the URL, it should override the jsdebug=y parameter that Retool automatically adds.

Hope this helps.



Hello Patrick,

thanks for your help.

The steps that you are describing, are exactly the steps that I was following as well. Unfortunately, it doesn't work for me (self-hosted retool, stable version 3.33.8).

Even, when I put the :jsdebug at the end of the URL, retool will always append another :jsdebug=y to the URL that is actually used in the the iframe that retool generates.