SQL Select query with a "@" character

Hi, I have a simple query to run, which works fine, when i test it with phpMyAdmin. In retool it is:

select email from user where email="{{ txtEmail.value }}" limit 1

Where txtEmail.value of course contains a @-sign. The query rans "successfully", but does not return the given email-Address. Again: It is a working sql-statement, when i try it on the server.

Any ideas? Am i doing anything wrong, or is it a bug?

If i change the statement to this:

select email from user where email!='' limit 1

It brings me the first email-address of the user-table. But how do i get an Email-string working in that query?

Edit: The Solution:

One more information: This query was bound to the onChange event of the "txtEmail". I tried to delete that event handler -> and it worked immediately!

And now it comes: As i added it again, it kept working :grinning_face_with_smiling_eyes:

In my (very short) experience, the retool-editor is a little "buggy". I do many window reloads in between, because i saw some weird stuff when i edited too long without reloading the tab.