SQL - Number is a String


Hi at all,

I'm a new Retool user, and I hope to be a persistent user :slight_smile:

I'm having a problem with a numeric column, that is saw in the statistics modules of Retool as a string.

1 - My column in Oracle is a Number :

2 - The result of my Query (when I run It in DBEAVER) is a number :

3 - When I try to add the value, I've got this message that is teling me that my result is not a number but a string :

My request looks like this :

When I add It into a column, it shows a number :

Do someone has an issue ?
I read a lot of posts on Retool community help, that are speaking about the same problem on Postgre. I tried a lot of things, but nothing is working !!!

Ex : Convert the result into an Integer, but I think I don't use the good way :

Do you have an idea of what I can do to use the result of my SQL Request as a number, to use statistics tables ?

PS : I think I will start to learn Javascript, because as I understand, It's better to know this language to use retool !!??

Big thanks by advance !!

In the column
Screenshot 2023-07-28 at 9.46.15 AM

Thank you very much for your answer !!!!

I think It's another thing that I don't understand !!

The error has disappeared, but I see this now :
2023-07-28 15_55_56-PPY-Monitoring-Interne _ Editor _ Retool

I think that retool don't choose my value, but the full Data.
How can I say to retool in the formula "use the value 10821.97" ??

I'm really sorry If my question is so basic but I'm a novice !!!


Thank you very much ScottR, you didn't gave me the answer but made me do a big jump !!!

The code that is working is : {{_.toNumber(query1.data.SUM(CANETTTC)[0])}}