Slack chat.postMessage text interpolation [object Object]

When I post a Slack message from a Retool Workflow, any interpolated values in the text field are rendered as [object Object] in slack:

Screenshot 2023-12-05 at 10.36.06

I tried this from a Retool app and it works as expected: the value is interpolated correctly in the slack message. This bug only occurs in Retool Workflows.

Hey @omarkhan! That's definitely strange and I would expect this to work as is. Could you try {{"Testing: foo"}} or {{"Testing: " + "foo"}} to see if that makes any difference?

With those inputs it posts [object Object] to slack:

Screenshot 2024-01-11 at 09.28.08

It seems to be working as expected for me like this! Could you try putting your text into a JS code block like this, and then referencing that code block? Seems like the query thinks the content in between your double curlies is JSON/not just a string.

That works! Thanks for the workaround.

Still very odd behavior, considering in works as expected in a Retool app.

Yeah, very odd indeed. I'll look more into why this wasn't working for you—thank you for surfacing! And glad to hear the workaround worked for you :blush: