Retool Unresponsive Page

Hi, I'm experiencing a problem on a particular retool page.

The page just kept on loading and shows Page Unresponsive Box which I have two option: Wait or Exit. If I choose to wait, same thing happens.

I tried to open other retool page that we have but they are working properly except to this particular retool page.

I already tried to restart my laptop, open incognito, clear browser and cache but this particular retool page is still unresponsive.

It shows Error code: RESULT_CODE_HUNG

1 Like

I think I have the same issue, see

Using FireFox at least enabled me to change stuff on the page again. Chrome completely freezes as you report it, too.

Were you able to find a solution for this, it's been a challenge for me as well I think it's a bug with retool.

Using Firefox helped. I assume a proper fix has to be done by retool.

In my case even with firefox everything is freezed. Can you help me?

I believe I've found a solution by disabling hardware acceleration in the browser. Noticed as well that firefox is the only browser that does not have this by default.

1 Like

Sorry y'all are running into this.

Can anyone share an app export where this is happening? (Edit App > ... > Export to JSON). Attach in this thread or send to

1 Like

Thanks for the response.

Just sent the mail including a short video of the issue.

Having the same issue. Confirmed with Retool staff that it's a known issue that is being worked on. Firefox is also not a solution for me at least.


I can confirm that disabling hardware accelation also fixes the issue for me. Quite confusing.

has there been any update here? Im also seeing this problem with my app as of Saturday.
I was not able to use the work around of disabling the hardware acceleration.

Hey all, we've rolled back some recent changes, and the issue should be resolved.

Please let me know if you're still experiencing issues.

1 Like