Retool email resource running into error: Invalid login: 451 Internal server error

  • Goal: I have a button that when clicked triggers a Retool Email to be sent. It was working fine and then stopped working 2 days ago. I tested sending an email and it said:
    message:"Invalid login: 451 Internal server error"

  • Steps: I have tried clicking 'run' on the email resource, and I get the error (see screenshot). This is also happening for any Retool Email steps in my workflows. It's pretty urgent as this makes many of my workflows fail!

  • Details: It's similar to the previously reported issue here: Retool Email Internal Server Error

  • Screenshots:

Hi @megan The 451 error can pop up when the user exceeds the limits set on the email server for sending emails. The email server will not allow the user to send more emails than the limits set on the email server; these limits are set as daily or hourly limits to restrict abusive behaviour (here a bit of background).

Are you still getting this issue now?

Can you test the connection of your smtp resource in the resources tab by clicking test connection on the top right? I'd be keen to see if you are getting the same error message there (please can you share the error message from the console, if you get an error).
Are you getting any error when you try accessing this resource from outside of Retool?