RestAPI : network timeout at

I do a normal RestAPI GET https and http but get always : network timeout at

I do the same query in the same browser (copy and paste this URL as browser URL) : it works :wink:
I do the same query in Postman : it works :wink:
But the same query in retool : no chance


retool seems to have really troubles to handle IP addresses or DNS names.
I tried to use DNS names instead of IP addresses, and also failed.

The same result, Postman and Nativ Browser URL works and is able to resolve the DNS name
into a IP address but retool RestAPI strikes.

I have installed on the same system where the Browser is running a fake RestAPI Server

Any tool is able to talk to this simple http end point but NOT retool.

At the end - I found another thread that explains, retool software is not running in the end-user browser, it runs on the server side. So the public server tries to find the local private RestAPI IP Address. No way to connect.

But the retool Rest-API Guide and the troubleshooting section is not covering this fact.
So I waste of time to find out this circumstances.

But there exist tools like localtunnel to connect the local private end-point to the outer public world.

And retool offers a self-hosting variant to run the tool complete within a closed area.