[Regression] Table Changeset not being cleared

When saving a changeset to a variable the changeset isn't cleared.

Minimum reproducable app:

  1. Add transformer as data source with random collection
  2. Add table with transformer as data source
  3. Make fields editable
  4. Create variable
  5. Set table save action set variable to changeSetObject and select clear on success.
  6. Change data and Save
    -> Data is saved into variable, changeset is not cleared.


The save action seems to be broken generally. Even on just Confetti as action the changeset is not cleared.

Please fix this asap, this worked before and a critical app is depending on this.

Hi @Bernd_Strehl Thanks for reaching out! I'm looking into this internally.

Since you mentioned this is a critical app, would it work for you to add an event that clears the changeset until we sort out what changed in the product?

Something like this:

I tried this, doesn't work either.

Hi @Bernd_Strehl Thanks for following up :thinking: Can you share some screenshots of your current set up with the clearChangeset()?

Tested it again this morning and now the manual call to clearChangeset works. The automatic clear is still broken.

Ok I'm glad you have a path forward :pray: I will post here when we've fixed the automatic clear bug

Bumping because I am seeing the same thing - was this resolved?

Hi @jg80 Thanks for checking in! :disappointed: Unfortunately, we don't have a fix yet. I don't have an eta for this one, but I'll post here if I get any updates internally

If I can give my 2 cents as a customer: You should prioritise keeping existing things working, over adding new features.

1 Like

having the same issue here....

This seems to be fixed now, I just used the clearChangeset() function on a table and it worked.

2 posts were split to a new topic: table1.clearChangeset() only clears the first table in the list

I might be using it wrong, but this still doesn't work (retool 3.24.9)
When i don't use clearChangeset() it updates the data in the table, but it doesn't clear the changeset.

When I call clearChangeset() the query errors out because the changeset is empty.

Is there anything else I should try? Alternatively, what is the last known working version?

I tried building around this issue, by disabling saving if the table is fetching or if the changeset is empty, but it's telling me that false or false is true.


Again, I might be misusing it, but false or false should be false, not true.

Hi @dakes I believe it's evaluating the string "false || false" as true. If you put the whole statement in double curlies {{}} it should be read as false:


We still have an outstanding bug where the table changeset doesn't clear on save when its datasource is a temporary state. Is your table populated by a transformer?

What is the run script event doing on save? If the run script event is where the clearChangeset code is, it will run at the same time as table1_save and cause an error. I'd suggest moving your clearChangeset code to happen on success of table1_save

Another note is that if you have a table populated by a query, rather than a transformer, the changeset will not clear unless you trigger a successful update query and then trigger a refresh of the table (or trigger a clear changeset event).

Thanks to your help I was able to get it working :slight_smile:

1 Like

Glad to hear! :tada: