"portal "C_29945" does not exist" - Error Running Postgresql Query


When I run a query in retool on my postgresql connection I get the following error - * message:"portal "C_29945" does not exist".

The query works fine if I apply a LIMIT to around 4000 lines. Anything over 4000 lines or the LIMIT removed I get the above error?

The query without the LIMIT will only be about 5.5k lines and when I run it in pgAdmin4 I have zero issues.

Any ideas what could be causing this?


There are limitations as to how many rows you can pull down before it times out - why not leave the limit in there?


Prefer having the whole table available and its never been an issue when I run the same queries on the retool database, which is also a postgresql connection.

Also never a problem when I run SOQL, seems to be isolated to the connection I currently have set up?


@RA_SYD Did some research on that error and it seems like a Postgres cursor error. Can you share where that db is hosted?

never been an issue when I run the same queries on the retool database

Does the Retool DB have the exact same data as the original postgres db?

Hi Joe, the retool database has very similar data, just not at the same volume.

When I run SOQL queries from Salesforce no limit on the volume of data, so its annoying this postgres issue? Any ideas why this is happening? Thanks

@joeBumbaca do you have any update on this? My company has a large catalogue, so the limit at 4000k is abit frustrating at the moment? Thanks

see another screengrab with the issue