Popup code editor moves cursor while typing

Brilliant information, thanks for going to all the effort to document that. VSCode is our friend.

Sadly the query editor work perfectly on my end but none of the inline script editing works. Eg event handlers.

I will test it out this weekend. Many thanks!

Took this issue back to the team. Thank you for bringing awareness to this.

Happening to me too, and it's happening a lot - as in, every 10 or 15 seconds. I can't even type a single line without it jumping to position zero several times.
It started happening a few months back, but now has suddenly crossed over in to unusable territory. Slowing me down terribly, and it's very frustrating.
Happy to help debug. The app is relatively large, maybe it's got something to do with that and code completion?

Though tagging the workaround as a solution has caused this to be flagged as a 'solved' topic, which it really is not.

Same issue over here.. cursor keeps on jumping.

Hello everyone,

I am an engineer at Retool. Thanks to everyone for bringing this issue up; we're going to try and fix it as soon as possible.

If you'd like, feel free to send your app JSONs where this issue is occurring to francis@retool.com (using the Export to JSON option). This will help us diagnose the issue, and ultimately push out a fix more quickly!

Let me know if you have any other questions.

you're right it is a bit confusing, i removed the solution checkmark.

sent, the email included the question heh but ya I guess it'd be a question anyone might wonder: The files sent, they could contain PID, other information that probably shouldn't be public, or just private code. So, any files sent would be deleted after they no longer have a use and the file and it's contents would stay private for the team team/person using it right?

Do you still need an example app? I can send you ours.

Something I've noticed: It's as if it's resetting to a prior state. I've observed that when the cursor jumps to position 0, sometimes the last few characters I typed also disappear.

Correct, we will delete files are we no longer need them and files will only be shared with the relevant team.

Yes, it would be great if you could send us an example app this occurs on (and maybe even a screen recording of this occurring).

I see this happening all the time only in code pop outs. I also think it is related to the code helper popup. I think I only see it jump while that popup is being really forceful. What I mean is, sometimes while typing, you will have the popup appear conveniently when you pause or something. Other times it seems the popup is almost getting angry at you and it just keeps hammering into your face with every key stroke. I will start clicking the cursor into different spots to make it go away but the popup just keeps trying to drive new information infront of what I'm doing. I find the cursor will start jumping to 0 during these times the popup is sort of freaking out.

I'm still getting this issue also. I concur that it might be related to the code helper.

The cursor jumps to the start of the code whether it is in the code pop out window or just the regular script edit pane. btw @francis12 could we make that pane adjustable in width?

My app only has about 300 components, mostly tables in tabbed containers or modals containing forms (about 20 of them), so I don't think it's overloading the system.

Here's hoping they can track it down.

if it makes you feel any better, I just noticed the code popup for Custom Components doesn't seem to have this bug. hopefully a fix is just around the corner

Hi everyone, just wanted to provide an update that we are nearing the completion of a fix and anticipate a fix release next week. Stay tuned for an update next week!

That's great news. Spent this afternoon writing my code in sublime text editor and pasting it back into retool because it's just too painful trying to write in inline

Also noted today that the behaviour of this quirk changes depending on how I've formatted the codr block in the editor window or in the component panel.
eg trying to type in the or statement into this code block, including the || operator makes the cursor jump
{{myvar.value === false || }}
but if the code has a leading space after the curly braces it doesn't seem to complain and lets my type
{{ myvar.value === false || myothervar.value === false }}

might be nothing

1 Like

Hi everyone,

Just wanted to let you know that we have landed a fix and it will be available in Retool cloud version 3.30! This will likely be released on Wednesday. I'll send another update in this thread when 3.30 is released.

Let me know if you have any questions, let me know!



Hey All, just following up - this issue should be fixed. If you see this happen again please let us know.



sorry, but the problem persists in the self-hosted version 3.26.6.

That really gets us down :frowning:

If it helps: We use Chrome browser on a Windows 10 machine with a german layout keyboard.


Hi @Hendrik I checked in with the team & the fix will ship to self hosted in v3.30, which is scheduled to come out the week of Feb 5th.

the bug seems to be back and more annoying than before :sob:. It no longer moves the cursor up and down (yay), it only moves left and right and usually only a couple spaces.... thats the good and not confusing news cause I've also noticed things like:

while typing:

  • sometimes it will delete the last typed char then move the cursor forward 1 space
  • sometimes it moves the cursor back 1 space, deletes 1 or both chars before and after the cursor, then move the cursor forward 1-2 spaces.

while using backspace:

  • it will sometimes replace the last deleted char to the right of the cursor

while typing after using backspace:

  • it will delete a char to the left of the cursor then replace one of the last chars not auto-deleted to the right of the cursor
  • it can also do the things listed under 'while typing'

I tried my best to find all the cases and get the order of what it does correct, but it seems so random it's hard to duplicate a result. Hopefully I haven't missed too many possibilities.

when it moves the cursor, it will always delete something and it only sometimes will also replace a deleted char. it doesn't seem to always place this char to the right of the cursor, as it will occasionally put something to the left of it but I haven't noticed a pattern when it happens yet :man_shrugging:

i'm in the code editor for an onChange event of a CheckboxGroup (run script action) in a Module using Retool Cloud in Chrome