Oauth1 - how to do post request

I am trying to work with a 3rd part rest api. They use oauth1.0 I can successfully request the GET requests. But POST/PUT are giving "oauth_problem=signature_invalid" this error.

So can we do POST/PUT with oauth1.0 ? how should we pass the data in it ?

UPDATE: I get expected response via postman. I had to pass XML in body (raw->xml) so how can I do it in retool ?


Hello @mpmohi,

Have you tried the RAW body option?

Hi, @ugo.ago
yes, I tried it will response as invalid signature.

Hey @mpmohi!

What kind of signature method does your endpoint support? Unfortunately, Retool only supports HMAC-SHA1 and HMCA-SHA256 at the moment - is it possible for you to use either one of those?

hey @Kabirdas
endpoint support hmac-sha1, and get queries are working fine. Problem occur when doing post/put. sending data is not working or I can't made it work. Trying to work with this: E*TRADE API Document if that helps

Ahh I see, I'm afraid we might not support making post requests using OAuth 1.0 to that API at the moment :pensive: Are you working with the same resource you mentioned in this post?

Yes they are same, thanks