Multiselect with snowflake

multiselect with numbers isn't working when i tried reading data from snowflake. I tried with

  ARRAY_CONTAINS(ID::variant, SPLIT( {{multiselect.value.join()}}, ',') );

This is not displaying any rows in my retool table. Can anyone help here how to read the integer values with multiselect.
I tried with IN(), its working but i had to disable the prepared statements for resource.

Kindly help me here.

Thanks in advance

Hi @Jyothi

Seems like an issue of different data types - could you try this?

Hi @Tess ,
This is resulting the following error-

I'm not getting this error when i use the resource with 'disabled prepared statements'. But, in my i should not use that i have to use a resource with prepared statements enabled.

I saw a blog-

Here, you have mentioned that its a bug. May i know whether it is fixed if yes. How can i use it in my code. Can you please help.

Hi @Jyothi that issue was separate from any queries in Retool, but I believe it is still the case that you need to stringify multiselect data if you want to reference it in your table component filter settings

If you do end up turning off prepared statements, we recommend creating two separate resources one with it enabled and one with it disabled so that you can limit the number of queries impacted.

Can we see a screenshot of the schema for ABC and can we see a screenshot of the values for multiselect.value? Thanks!