MongoDB Write Resource is not working

Hi everybody,
I'm trying to set up a new mongo resource for writing queries.
I choose the write connection option:

The connection test works and everything looks ok.
However, when Im trying to use the resource in a query I get an empty tables dropdown along with the knex error - Required configuration option 'client' is missing:

I know someone has already faced this issue but they solved it converting it to read connection, but in my case I need the write connection because I need to use the mongoDB UI.

1 Like

I'm also facing the same issue, tried with azure cosmosdb for mongo and mongo official in both read works fine, write I'm facing an issue

The exact error is below:

@victoria Help needed

Hey, I've changed the connection type to read and it works.

Previously changing the connection type to read won't allowing to use the mongoDB GUI - might be some issue on retool side, but later on I've contacted the support and then after a few hours, I tried again changing the connection type to read and it worked and I'm able to use the mongoDB GUI along with updating the records.