Jira resource not working anymore

My resources that were previously using the Jira connection are no longer working, no changes in the app have been made and there haven't been changes to our Jira Cloud instance that I'm aware of.
The Jira resources use to constantly require authentication and now when running it says the "Client must be authenticated to access this resource." I have gone through the authentication process several times for the resources inside the app as well as on the main resource page. I've also changed it to use the latest API in the resource settings and nothing is working.
Anyone experiencing this or know if this is a bug on retool's backend?

Hi @aking43 Thanks for reaching out -- I am looking into this!

We had some users running into some unexpected errors last week, but it seemed to be related to this Jira incident

I will do some testing on my side & keep you posted!

Thanks Tess. We're currently doing a POC of retool and the app we have is setup to pull data just from the Jira queries and display it's capabilities. It was quite embarassing when we went to show what we've been able to do with it to one of the bosses and found out the JIRA API is having issues........:confused:

I'm so sorry to hear :disappointed: Our on-call team is investigating this currently, so I will keep you posted!

Thanks @Tess . Just as an FYI, I tried again this morning and it's working as expected. Not sure what was going on.

Hi @aking43 I'm glad to hear that! Really appreciate you letting me know. :thinking: It's still something that we're investigating. At this time, there's no obvious changes we made that could be impacting Jira resources.

In case the error comes back or if other users are seeing this error, I wanted to share the following:

One user just let us know that they had success in resolving this error when changing their domain sever variable on the resource set up.\

They were getting the error when using <your-domain>.atlassian.net as the domain variable, and changing the domain to api.atlassian.com/ex/jira/[cloud ID] resolved the error.

If you see errors and your domain is also using <your-domain>.atlassian.net, I'd recommend trying this change:

Go to http://your-jira-domain.atlassian.net/ > settings > billing > and then copy the ID in the URL of that page to get your cloud ID.

Then, set your domain in your resource set up to:

api.atlassian.com/ex/jira/[cloud ID]
1 Like

Hello, @Tess . I was having Jira issues last week (related to the incident above), and it started working again late last week.

However, starting today, my Jira resource in Retool stopped working. When I try to reconnect via OAuth, the following error happens:

unauthorized_client: redirect_uri is not registered for client: https://oauth.retool.com/oauth/oauthcallback

This error appears to be specific to Retool, as other apps I use are connecting to Jira the same way with the same account, and they're not having issues. Screenshot below of the error.

Also, per your suggestion above, I tried to connect using both the "[domain].atlassian.net" way and the "api.atlassian.com/ex/jira/[cloud ID]" way. Same error for both.

Any insights into the issue? Thx

I may have spoke too soon. It's having issues again.............

Thank you both! I am so sorry to hear this :disappointed: I'm checking in with our on-call team internally

1 Like

Hi All,

Thanks for your patience! I have some updates from our internal on-call engineering team.

1). For anyone that is using the "[domain].atlassian.net" syntax for the Jira domain, we ask that you switch to the api.atlassian.com/ex/jira/[cloud ID] format, as described above. Unfortunately, I have some new information that changing the domain in the resource page, isn't currently updating existing queries' domains :disappointed:. We are working on a bug fix for this, as it is very tedious, but in the meantime, you will also need to manually change the domain syntax in each of your app queries to match the cloud id syntax in the resource setup.

Please ensure your resource domain is in this format:

And also ensure that your queries are in the same domain format:

2) In addition to the above issue, there is a regression where the wrong callback url is being used for resources that have "Share credentials between users" checked ON. We are working on a bug fix for this & are targeting end of this week or early next week for a fix. In the meantime, you can uncheck this setting (and follow the steps outlined in #1) in order to use the resource.

@Tess - Thanks for the info, but it still does not work. The redirect_uri value is still invalid when Retool tries to obtain OAuth permissions from Jira.

Hmm @plwolfe I can't reproduce that behavior on my side :thinking: Can you share a screenshot of the resource set up?

@Tess - Here you go. Screenshots show each step of the way trying to authorize w/ Jira via OAuth. Mind you, this has worked for 6+ months and just stopped working on Monday. Sensitive info redacted.


Hi @plwolfe,

We still haven't shipped a fix for the regression on the "Share credentials between users," so that checkbox needs to be un-checked in order to successfully authenticate. I realize that is not a sufficient workaround :disappointed: Our team is actively working on a fix!

Thanks for the support @Tess . I can confirm that switching it to api.atlassian.com/ex/jira/[cloud ID] in the main resource, the resources in the app, and unchecking share credentials has fixed it for me.
Please let me know ASAP when the fix is available.

@Tess Thanks. I confirmed that unchecking share credentials allows me to connect, but unfortunately, the workaround doesn't work for our use-case.

The users of our Retool app do not have Jira accounts. They are seeing a narrow slice of tickets in Jira from one account that has permissions. So they rely on that shared credentials feature.

I appreciate your support and hope this issue can be resolved quickly. This issue has been very impactful. We are evaluating adopting Retool for our company-wide enterprise backend, but a week-long outage (or potentially longer) like this means we can't rely on it. That's unfortunate, because otherwise Retool is a fantastic tool.

@Tess , I keep having to constantly reauthenticate the Jira resource for it to work. Is the Jira resource designed to work this way? Is it a bug? Is there a way to add this button to the app so the other users don't have to go into the app and have edit permissions to authenticate?
Hope that makes sense and appreciate the help.

Hi @aking43 You can add an auth login component! This will allow end users of the app to initiate the auth process as needed.

Thanks for the feedback @plwolfe and it definitely makes sense that this wasn't a stable solution. :disappointed: We take stability very seriously, so I do want to at least share some additional context. We looped in our on-call engineering team internally when the "Client must be authenticated to access this resource." errors started to come in. It was a little tricky to troubleshoot as the errors were somewhat inconsistent, and the timing of them also coincided with a Jira incident. It did turn out to be a regression that could be solved by manually modifying the domains.

As we continued to monitor for these errors, we also saw reports of the share credentials toggle not working. This behavior is definitely concerning, but it seems to be separate from the "Client must be authenticated to access this resource" regression as we hadn't made a recent change to this code. This is now fixed, so you can share credentials using the Jira integration

I also face this error Client must be authenticated to access this resource and I've did all the above:

  • use the JIRA api.atlassian.com domain
  • disabled the share credentials
  • have a Jira login button in my app

Hi @assertnotnull Thanks for reaching out about this!

Are you seeing this error on an app query? Does the Jira login button successfully take the user through the full oauth flow?

What happens when you authenticate on the resource set up page? If you click 'See token status', do you have any existing tokens?