Issues with switch not toggling and components not updating in edit mode


Ive started to notice an issue over the last couple of days when editing apps. First issue is that the "switch" component no longer seems to toggle in edit mode. If I preview the app it works as expected.

Also having issues when adding new components. When I then edit those components (e.g. add labels / default values etc) the editor screen does not update with the new values. To get them to show I have to refresh the page/app and pull up a record.

The issue with all components seems to be intermittent. It was doing it earlier this afternoon but Ive just added a couple as a test and seems to be working fine again. However, the issue with the switch / toggle component is still occurring.

Hope you can help.


Hi @Rob! Thanks for reaching out about this! I'm looking into it. I am not seeing the same issues yet :thinking: Any chance you can share a copy of your app?

Out of curiosity, are you using the legacy or latest runtime (indicator in bottom left corner)?

It may also be worth testing out your app in an incognito window to see if that is any different

Hi @Tess

Thanks for taking a look. Checked again this morning and still doing the same thing. Also tried in Incognito window and same issue. Tried to upload a screen recording but it wont allow it. Yes, using the latest runtime. Did consider changing back to legacy yesterday but didnt know if there would be any knock on effects?

Happy to share the app, what do you need, just a link?
App Link


1 Like

Hi @Tess,

Any luck looking into this? Checked again just now and its still not working.



1 Like

Hi @Rob_Faulkner Thanks for checking in! I stepped into your app, but unfortunately, I am not seeing this same behavior :thinking:

I made a copy of your app (Customer - New - copy) to further test. Since some of this is intermittent, I will try again a bit later. Are you using Chrome?

You could try downgrading to legacy to see if that resolves it, as that would narrow down where our team needs to investigate. Maybe try downgrading my copy of your app to legacy so that it doesn't impact your live app.

Thanks @Tess ... yes Im using Chrome (up to date) on Mac OS 13.2.1. I've tried clearing local cache / cookies etc and its still doing the same thing, just tried it now.

Downgraded the copy you made and also doing it on that version for me too. As I said before, the preview works fine, just when in Edit mode.

Hi @Rob_Faulkner

I have a few questions for you!

1). If you make a new app with a switch component, do you see this same behavior?

2). If possible, could you share a screen recording via chat or to

3). Can you check to see if there are console errors when you attempt to toggle the switch?

Hi @Tess

Made a new app and switch works fine in edit mode.

Ive made a screen recording and sent to the support email. Couldnt see any errors in dev console just a few warnings. Left the window open in the screen recording so you can see this and attached the console log in the email also.


Hi Rob,

Just sent you an email. I was able to reproduce this based on the recording that you sent over.

I'll post here when I get updates from engineering about this bug! Thanks again for reporting :sunglasses:

For anyone else running into this, the current workaround is to hold down shift on your keyboard while clicking the components. It is impacting the switch & checkbox components

Thanks @Tess got your email!

Glad it wasn’t just me doing something stupid :grinning:



This should be fixed :blush:

Thanks @Tess all working fine now :sunglasses: