Switch component not working within list component

Hi @Tess ... the issue from this post switch not toggling seems to have resurfaced in the last day or so.

It only seems to affect switches that are within a list view. As before holding down shift while clicking the switch seems to work, however even this seems a little intermittent. Only have the issue when editing the app, works fine in preview.

Let me know if you need anything further.



Hey @Rob_Faulkner can you share what Retool version you are seeing this on? Thanks!

Hi @joeBumbaca, its 3.14.0 (see attached screen shot).


Screenshot 2023-09-26 at 16.28.14

I see this issue now as well...
version 3.15.0 on cloud

Hey @ScottR @Rob_Faulkner I'm unable to reproduce this. I do see that it's difficult to get the cursor in a place where the label isn't covering the toggle itself, which does make this difficult to do. But once I get the cursor in the right place it does seem to switch consistently. Mind sharing an app export or screen recording?


I know there was an issue that recently was fixed having to do with using a dark theme - my switches are in a List View component and neither of them work...the app uses a dark theme
Going to reach out to support directly if this isn't fixed soon...
Edit - Added the following:
As noted below - this is happening in Editor mode only. - while not urgent - it needs to be addressed...
Screenshot 2023-10-04 at 8.03.13 AM

Hi @joeBumbaca,

Still doing it on mine (when you see it working in the recording its when Im pressing shift).

Just wanted to reiterate, it only does this in edit mode.
Only other thing is that when I first reported this it was doing it in all switches that were within a list item. It now only seems to be doing it in one of the switches in one of the list items (see below).

I've created a dupe of my app here if you want to take a look:

Customer Page - Retool Debug

  1. Search for customer 7322 and go to the Subscriptions tab.
  2. Expand one of the subs on the left. The "Aggregate Min Charge" switch doesnt work without using shift key.
  3. Expand one of the units that appear on the right (also list items) and these work. (Active / Locked).

With regards the comment from @ScottR, my app is using light mode.

Let me know if you need anything further.



Hey @ScottR you have support directly right now! As soon as we can get a reproduction of the issue, then we can get a bug report over to the core engineering team to take a look at. Placed a dark theme in the app and the switches still work, so that doesn't seem to be the core issue, thanks for confirming @Rob_Faulkner. I am definitely testing this in editor mode as well.

Unfortunately can't log into your instance, but happy to look at an app export if you don't mind sending that over. Also looks like you both have hidden components nearby, so I'll explore that. Are those switches in containers other than the listview? The closer I can replicate the structure the better.

@joeBumbaca Yes support is available but only through email - used to have chat (not sure if it is the time of day that chat is available) I'll email support for now.

Chat isn't available currently, you can check out our Contact Retool Support page for updated information.

You are more than welcome to email in if you would like. But you also have a support team member right here working on the issue!

Any additional information with regards to the listview / switch set up, or an app export would help resolving this. Thanks!

Hi @joeBumbaca

Apologies, last time I had a similar issue the support team just seemed able to access it with a link. Do I just download in JSON and upload here?

This app does only have switches within the list view. However, as a test I added switches to the same app but outside the list view and these worked fine when I tried it a week or so back.



No problem! For security reasons, we no longer step into instances, but definitely makes sense that you had that experience previously.

Feel free to export it as JSON, and upload it here. Or if you prefer you can email it to me directly, joe@retool.com

Thanks @joeBumbaca, Ive sent the file over by email.

1 Like

Hey @Rob_Faulkner, thanks for that export! Haven't been able to reproduce the issue in my own new apps, but do see the issue in your app. I've gotten the info to our eng team and will update you here as I get new information from them or if we need anything else from you. Thanks again!

Thanks for taking a look @joeBumbaca . Hopefully something jumps out at the eng team. :crossed_fingers:

1 Like