Issues with dropdowns, multi-selects, and variables

Hi! I am working on my first Retool app and having several issues that are stopping me from moving forward.

Variable Issues – Several of my variables or transformers are showing an undefined error, while at the same time showing me a value in the green preview window. This is causing queries or components using that data to have issues. Even when I inspect the variable or component’s state, I see that it has a value, but things just aren’t working as they should.
Variable Undefined Issue

Dropdowns, Multiselects, Tags – I have spent way more time than I care to admit on trying to get the dropdowns working how I’d like them to. I have tried setting the data source to the table’s data, to the query, to the query’s data, I’ve tried things like {{>d.organizationTypes) }}, and many variations of this. Following the documentation usually leaves me with the record’s ID as the available options. What I am trying to accomplish is to:
a. Have the multi-select offer all the unique values in the column as options.
b. Have it show the current values correctly and be able to add/remove values.

Here's an attached app json with setting up a multi select, setting the list to be a unique list and also passing off the default value.

mutli-select.json (25.0 KB)

Can you explain how this helps me please? I'm not seeing it.

Hi @Sam_S, try creating an app from JSON by using the attachment from @metechnologies's last post. Explore the settings for each "Multiselect" component, they should work for your use case.