GUI mode not available after granting service acct write access to all datasets [BigQuery]

I'm trying to enable GUI mode to write to our BigQuery warehouse from Retool, but no matter what permissions I grant, I can't get GUI mode to become available. I've gone as far as granting BigQuery Admin and Data Editor roles to the service acct to test.

This was after I followed the recommendations found here: BigQuery GUI mode (Write) - #3 by victoria

Hey @fordicejw!

Given that the account has admin access it BigQuery I'd imagine it has sufficient permissions to show GUI mode. Would you mind sharing a screenshot of your resource setup screen as well as how you have permissions configured on the BigQuery side?

You can DM me as well or write in to us from within your Retool instance if there are any parts you're willing to share just not publicly.

Continuing the discussion from GUI mode not available after granting service acct write access to all datasets [BigQuery]:

Hi @Kabirdas,

Here's the list of roles I've applied to the Retool service account. I know it doesn't need all of them, but it hasn't worked so far so I think something else is wrong.

Let me know if you have any ideas! I've tried deleting and recreating the resource, logging out and logging in, duplicating the app, etc. Not sure what else to do.


:thinking: those permissions should certainly be sufficient for using GUI mode with BigQuery. Have you tried generating a new key for the service account and using that just to make sure that the key you're using is associated with the correct account?

If it's ok with you I can also step directly into your org and take a look to see if I notice anything odd, just let me know :slightly_smiling_face:

It's definitely ok if you step into our account to see what's going on. I've tried your solution just now and it didn't seem to work. :confused:

@Kabirdas any update on this?


Hey @fordicejw!

Taking a look at this with a couple of team members and I'm not sure yet what's going on here. While we investigate this, can you try create a copy of the BigQuery resource with the "Show write GUI mode only" enabled?

That seems to at least show the GUI, I'm curious to know if you run into any particular errors when trying to write with that new resource or if the writes execute successfully.

@Kabirdas that seems to work, but it's messy to have two different sources for the same thing solely so we can access GUI mode when it should be available on the other source according to your documentation.

Could you keep trying to find the root cause of this please?

Yes! You should definitely be able to use both modes within the same resource, I'll let you know here when we've found a fix.

This happened to our resource as well. We can write with raw sql, but it's annoying to convert.

Wondering if there is a fix?

Hey @Hunter_Anderson, it's gotten some eyes on it since the issue was first filed but there's no fix as of yet. Does creating a new resource with "Show write GUI mode only" enabled give you access to GUI mode? Or is that failing for you as well?