Form does not submit on mobile

Suddenly my form to add a new entry into the retool database does not work on the mobile app when using it from the phone. the error message is

addNewItem failed: insert into "inventory_items" default values returning * - null value in column "item_name" of relation "inventory_items" violates not-null constraint.

All fields, including the item_name field are filled out.
either way, the form works perfectly when I use it from within the dev area on desktop.
I have tried un-checking the "Reset after successful submit" even though this wasnt a problem before, however this does not fix the problem.

There seems to be something different with how my form is behaving between different platforms.

here is a screenshot of my query setup. pretty basic.

and here we can see the form filled out, and the live output of the state of the form as the query input sees it. all fields are coming through perfectly.

dead in the water on my app, no form query table inserts work at all. would be great to get some help with this. feels like a bug.

I've discovered that the problem exists only on Android. I've tested it on 3 phones, and both Android phones failed. The weird thing about this is that it worked on my android when I was first getting started, but somewhere along the line it stopped.

I'll keep tinkering I guess, not getting much response from any of the support channels. :pensive:

Hi @cworf Thank you for the update about this happening on Android! We are doing some testing to try to reproduce this internally so that we can work on a fix

1 Like

Hi @cworf we released a new version & aren't seeing this issue in our testing. I wanted to check in to see if you're still experiencing this issue?

no it appears to be solved! Thank you!!

1 Like

Ah so glad to hear! Thanks for letting us know :pray: