Extend query timeout from default 120 seconds

I am trying to run a procedure that has an average execute time is 5-8 minutes and retool default timeout canceled the query after 120 seconds. Is there a way to work around this and allows longer queries to finish execution?


1 Like

At the moment there is no direct workaround for this while using the cloud version of Retool, since it is a multi-tenant environment supporting longer execution times has more potential for impacting performance for other user’s queries. In the enterprise, on-premise version you can modify this setting since you would be the only organization affected if those queries ended up timing out very often.

If your user navigated away or the app crashed, that 5-8 minute query time would never complete but most likely the action your API is running would still happen which makes planning out the user experience challenging. In general, it might be more ideal to initiate the procedure with one query, and then periodically poll to check whether the operation is complete and retrieve the result.

Thanks, Alex for replying to this issue. Actually, the query I am running is a dynamic SQL select query that is fetching data from 3 very large tables having records count more a million. Can you guide me through the process to get an enterprise, on-premise version?


I asked someone from our enterprise team to reach out! Let us know if you have any other questions!

Updating this thread for those who stumble upon it! This customization option is available for anybody who chooses self-host their Retool instance. You'll just need to set DBCONNECTOR_QUERY_TIMEOUT_MS in your environment variables.