Error when using Redis queries

Hi there! I have created a few Redis queries and tried to run them. The behavior is a bit inconsistent:

  • In about half of the cases, queries run successfully as expected
  • In the rest of the cases, they fail with an error: sometimes it says Unknown error and there is a request with 502 Bad Gateway status in DevTools, sometimes the message is request to http://172.20.20.99:80/api/runQuery failed, reason: socket hang up

I have a MongoDB server set up on the same machine and connected to Retool. Queries from it always succeed - so it’s not a connectivity issue. Is there anything I can do from my side to fix this error?

3 Likes

Any luck with this? Having the same problem running redis queries against the ssh connection to a bastion aws box.

Hi Alex,

No luck unfortunately. We’ve tried to keep in touch with Retool support on this issue – but all we’ve received in the last few weeks is:

Hey there - I have added this to the bug backlog, but I am not sure when it will get picked up as our engineering team is quite backed up right now. I have a note to notify you when this issue is resolved.

Ok cool, really appreciate the update. I can use the local instance for now anyhow to get my page constructed which is convenient.

Cheers,
Alex

Hey @olexlyap, @alex_at_yonder, @zigguratintl,

Apologies on how long this issue has been outstanding. It’s been difficult to track down and prioritize but it is definitely on our end.

It is now one of our top priorities to solve this issue. The work is in progress and it will be at least one engineer’s main focus till it’s fixed. I don’t want to over promise, but at the moment I expect this to be fixed within 1-2 weeks.

3 Likes

Hi @alex-w Any updates with this?

1 Like

@olexlyap, @alex_at_yonder, @zigguratintl

We have improved the redis query performance considerably (I’m no longer able to repro the timeouts running a loop of the same query 1000 times) but I’m not quite ready to declare this all-clear.

How do these timeouts frequencies look on your ends now?

@alex-w, preliminary tests on my side look good as well!

Hello @alex-w! I tested queries earlier today and they worked properly, but now I’m experiencing the same timeout error every time I run queries.

Hey @olexlyap! I just encountered the same thing on one of my test instances, but not on the other :thinking:. Re-saving the resource in the one that was timing out seemed to fix it for me- can you try making an inconsequential change (adding and immediately removing a space to the title for example to enable the Save Changes button) then saving the resource?

@alex-w Renaming the resource did it for me! I will do a few more test runs tomorrow and let you know if there are any issues. Thanks for the assistance!

1 Like

Hi @alex-w! I have done some more testing today. Sometimes my queries started failing again, and I had to rename the resource again to fix it. Currently I can’t provide any details on how to consistently reproduce this. It seems to me that I have to rename it every time I start a session (load the page), although this behavior is not consistent