Disable cache for REST API

I have two queries: getItems and updateItem. When I do updateItem, I also do a updateItem to refresh with the latest data.

But I am having an issue with the delay to show the updated data. I've confirmed in my backend that the item is updated, but takes a couple minutes to get the changes reflected in UI.

I've already disabled Organization Settings -> Advanced -> Cache queries across all users and all queries caching.

Edit: using direct Postgres query this issue does not happen, only with REST.

Hey, happy to help! Have you tried adding a success event handler to the updateItem query that retriggers the getItems query?

Yes, I've tried this.

My workaround was to use GraphQL API, which is working as expected, so I am using it!

Okay, was there another issue you needed help with then?

No, thanks... but I think you should do some testing to see if it is a bug.