.data property is undefined

Hi Community,

I had a problem with the property .data related to form component, she was undefined since last friday.
I tried on other old applications and a new one too it exists. Earlier i tried again on the main application and it reappeared :sweat_smile:
Capture d’écran 2022-06-13 173736

Has anyone had this problem before?

Hi there,

Could you share what the query was, and did you see any error messages?

I didn't get an error message, just the .data property in no longer available on the form component.

Hi Aziz,


Is the issue that the form data property is sometimes defined and sometimes undefined?

@awright22 Exactly

Hi Aziz,

Could you provide more specific implementation details to either be able to reproduce the behavior/make suggestions or clarification on what you expect the behavior to be?

\

@awright22 As I said previously, this application has been working fine for months.
And one day, it doesn't work anymore, on debugging I discovered that the data property no longer exists on form component, and it reappeared another day.

Hey Aziz,

Sounds like you might've just run into a regression/bug that was since fixed. To confirm, it's working as expected right now?