Clicking Apps from app list is sending me to 404s

I'm trying to open my apps from the apps list in retool. some of the apps open, but some of them are taking me to the URL https://org.retool.com/pageNotFound
. The page shows: "404 :(" I have tried copying the offending apps, but the copies do the same thing. This is pretty concerning as I can neither open, nor edit these apps.

Hi @jgschaaf, happy to help! :slightly_smiling_face:

I'm sorry you are dealing with this 'not found' error. There may have been an issue with your apps' "uuid". Let's try setting a Custom URL for our applications and see if this fixes it.

For all the apps where this is happening go to "App Settings" -> "Page Settings" and change the end of the URL to something of your preference.

For example:

Please let me know if this is still happening after we update the "Custom Url".

Hello Paulo,

I'm facing exactly the same issue and chaning the "Custom URL" doesn't change anything. And it is critical to us as we use Retool Portals.

Just after logging in, our users are redirected to a 404 page due to this problem, and can't leave that page in any other way than editing themselves the URL in the browser.

Something goes wrong with the original "appPath" (not the custom url), especially when calling the "lookupPage" endpoint.

I get this error in the console, and when you look at the appPath, it is not well formatted. It should be something like "/apps/d88c1060-cb46-11ee-aaad-4b3d08fccc4c**/app/**dashboard" instead :

app.792a4858.js:2 Uncaught (in promise) Error: Could not find page with appPath /apps/d88c1060-cb46-11ee-aaad-4b3d08fccc4cdashboard

And the request looks acutally weird : https://siello.retool.com/api/pages/lookupPage?pagePath=%2Fapps%2Fd88c1060-cb46-11ee-aaad-4b3d08fccc4cdashboard&showLatest=false&releaseVersion=&historyOffset=&mode=view&workflowRunId=

Thank you for your help :pray:

Ok, I just found that this starts happening with an app if this one has been moved to another folder. And this not happening anymore if the app is moved back to its original location, when it was created.

PS : Duplicating the app or exporting/importing JSON in another folder doesn't do the trick.

1 Like

Hi @Thomas_Delobel, welcome to the forum! :wave:
Thank you for looking into what is causing the issue and how to go around it, this is super helpful for our engineers to fix the bug as they now have a lot more context. I created a bug report!
:lady_beetle::memo: