Can't query Google sheets where column name is a multi word string

I have a Google Sheet as a resource, however I'm trying to create a search bar that searches a column with the name "Part short desc", I have tried double quotes, single quotes and neither work. This is my SQL query:

select * from {{ }} where 'Part short desc' ilike {{'%' + searchBox.value + '%'}};

If I change it to one of the single word columns it works fine without quotes. Am I missing something?

Hi @Vince_Woodruff, have you tried back ticks? "`"

Thanks, back ticks doesn't work

I also tried changing the id and the label to a single hyphenated word just to test but no luck, not finding much in docs either...

The only thing I find lacking in your query is using an alias, ...FROM {{ }} T WHERE T.*Part short desc*.... Replace the asterisks with backticks. Backticks work as I was able to run the following queries:

spreadhseet query

query json with sql

@jocen please see screenshot, not working and you can see the string is not being seen as a whole entity as 'desc' is a different color than 'Part short'. Is there documentation somewhere on this? I haven't been able to find.

I figured it out, you have to use brackets [] on the column name, so [Part short desc] worked