Automatically Generated Form not working - Error every time?


I have been getting extremely frustrated, stuff works.. then it breaks (for no proper reason).

I can not get forms working again. I have even tried deleting the entire app and starting again from scratch with a small two-column table. Still doesn't work.

Here is what I have done:

  1. Connected to my working "MySQL" database. (30 tables, all populated).

  2. Dragged a table onto the canvas, created a basic [SELECT * FROM] query and linked the table to it.

  3. Dragged a "Form" onto the canvas, clicked it and selected "Generate fields from a database".
    The form looks like it has been created properly, however when I fill out the only two fields (ID and name), with 1 and 'john' - when I click submit I get an error message:
    ER_BAD_FIELD_ERROR: Unknown column 'numberInput1' in 'field list'.

The error is basically telling me that numberInput1 and textInput1 are invalid, but those parts are automatically generated and have no user input from me at all.

As I said, I even tried deleting all apps from the account and starting again, but i still cannot escape this error. My canvas never even got to be complex anyway, as I was still learning -- I find it hard to believe it is this buggy?

What am I doing wrong?


Hey Nick, I'm an engineer at Retool. I believe you ran into a bug that was pushed recently. The fix will be deployed soon.

If I'm reading your report correctly, your query has {{ }} in the "Changeset" field. If you convert the form to use "Key value pairs" instead of "Object," and put in values for your columns like in this image, your query should work. Thank you for your patience while we get this fixed.

Hello Nick!

I am on the Support team here at Retool. Just following up and seeing if Yogi's suggestion helped at all. We are constantly improving and making changes to Retool and its capabilities. I definitely understand that certain aspects can not work as expected and become very frustrating. We're always here to help either on the community forums, through chat at the bottom of your app, or you can even email support. It does seem like this bug is set to be fixed very soon, but I imagine Yogi's suggestion above will do the trick. Please, let us know!

Thank you,



Thanks for your replies.

As you can see in the screenshot, the 'changeset' field is empty.

I deleted it all and started again from scratch (to see if I could get "just" the form working on its own -- as you can see in the screenshot, I still can't get it working).

Hope you can help.


Hi @nrpeyton,

It looks like you're missing the changeset toggle in your query.

What version of Retool are you running?