Wont lookup by number

I have retool hooked up to airtable via sync.

Trying to have records returned when searched for by user id. Using numberimput but it wont return records.

I am sure I am doing something amazingly simply wrong.


Hey there! What is {{ numberinput1 }}? If it's a component, you may need to grab the value by doing {{ numberinput1.value }}.

Let me know how that goes!

I realized that was missing and changed it to .value

Still not pulling back results and getting this " operator does not exist: integer ~~* integer"

For some reason it looks like it is taking input as currency?

Here is video walking through it all.

Thank you for that loom! It seems to be working for me, which is good news and bad news I suppose :sweat_smile:

If you delete your number input and create a new one, does it still show you that same error?

Victoria for the win! I changed islike to = and like a thunderbolt from lightening it started working!



Awesome! The error we gave back is super unhelpful. Glad you got it work regardless 😊

1 Like