Weird issue with versioning

Not sure if this is a bug or something.. but for one of our apps, exactly one team member could not get the current live version (0.2.11) no matter what. Worked for everyone else, for a variety of roles. But that one team member was stuck on 0.2.8 even when he went to incog mode, went to the MAIN app, then selected that app from the menu.

I didn't realize at first it was a versioning issue, as the problem was specifically that initial data load was fine, but the dropdowns for searching weren't changing the displayed search results.
I notice he was getting weird UUID errors in console, so I linked him the URL for the app, which worked. After confirming that everything now worked, he went back to MAIN, selected the app from the menu again, and everything was as it should be.

Hey @haneul !

Not sure if either of these 2 facts are helpful.

1. Within permission groups you can make it so that users cannot access unreleased versions (i.e. anything that's not currently published/live if I understand it correctly)

  1. Make sure to check URL's for these parameters which can be hard coded to a particular version

    Customize app URLs | Retool Docs

I good start for debugging would be to post all the different links that were used in full. :slight_smile:

But Retool does (scarily) still have it's quirks every now and then, so it might be on their side.

Checked those issues, was weird, issue never happened again after they got the v0.2.11 link. Only unusual thing was that they were the only team member using Greek as their browser language, but I mean... I assume it was something else haha.