Variable name beginning with integer not working


i have an API Endpoint connected to Pipedrive. Using custom fields, they generate field_variables sometimes begin with an integer, example response:

"82d045477f63428d8f7aa73e59e2f784f2cb1599": "25",
"cef98c7d2f3fcb78725112305e4ea05c92236b2f": "27",
"19be3e003aff346de7bddef3ed0f7ed66609906a": null,

Running the API query, i get the results into a table. But trying to select from this values does not work, as javascript variables should not start with integer.

Is there any workaround to still address variables beginning with integer, as there is no option in pipedrive to set variable name not to start with integer?

Hi @whynot !

Try putting the property name in square brackets with single or double quotes like this - {{table1.selectedRow["7da5d3f69ce6dae9d5a895af5180183db57a0d56"]}}

Hi @mitchmess,
thanks for this suggestion. I tried and it failed both with single and double quotes.

The attribute is there in the response:

Any other idea?

Hello @whynot, just try to delete last dot['xxx'] ->['xxx']

great, that worked! Thanks!

1 Like