utils.openApp has gotten slower with new side effects

  • Goal: Using multiple apps, which navigate between them. For example, we have a table, and each row opens an app with the data for that row as a parameter.

  • Steps: using utils.openApp in the row click (or possibly Row Select, and sometimes we do on a button click).

  • Details: Has worked well until about 1 week ago. We are using purely cloud, latest versions. It all still technically works, but before opening the new application, the existing app now resets. It appears to reload, and run all of the initial queries, and then finally open the new app.

This started happening all around the same time with all of our apps, which were all built at different times. A noticeable screen refresh happens. If I use the table method and filter on a search term, then click one of the rows to open a new app, I will see:

  • full screen refreshes.
  • contents of the table refill w/o a filter
  • contents of table get filtered again, showing results that were there before
  • finally, new app loads.

I am not sure how it worked before, but I thought it worked via a full page reload. I am not seeing that anymore and is using pure javascript/react to load the new app now.

I suspect a change was made to try to make it faster, but it had the opposite impact

Hey @Garr_Godfrey ,

Could you take a video of the issue? I wasn't able to repro and would like to know exactly what's happening. Here's me trying to repro the issue, but not shedding any light on the situation


I'm not sure how you embedded the video. None of the file formats seem to support video.
I am on Mac Chrome. I haven't tested on other browsers.
But the linkages are using the same approaches you do in the video.

I managed to find/fix one aspect. Because the new Tables didn't originally support "Click Row" event, it was set to have a timeout that cleared selection after a second if the new app had not loaded. (with only 1 row, cannot trigger Select Row on it if it is already selected). That seems to have taken care of the table rendering.

But, it is still slower than it used to be with a noticeable flash. It actually doesn't happen when using it from the editor, or even in Preview mode, only if we are not in EDIT mode at all.

Hi @Garr_Godfrey, we're happy to hear you were able to fix one aspect of the issue! :slightly_smiling_face:
Feel free to upload your screen recording it to a TPA like Loom and just drop the link here. We would love to take a look at what is going on.