Using Array in Where Clause - Any Tips What I am Doing Wrong?

I am not sure what I am doing wrong. I am trying to use an array of values in a where in clause using oracle. The helper string text shows that the query evaluates correctly - but I get an error about arrays only being allowed in PL/SQL. Attached are screenshots of what I mean.

Doesn't work but the "String" in the green box shows that the query is exactly the same as above

@Kabirdas - any chance you have one of those nifty work arounds for this as well?

Try using = ANY(yourarray)

I should have mentioned I have tried that too - but get the same PL/SQL error

Is your syntax correct? Since your returning an array as the data shouldn't it be

I tried what you mention, but it doesn't seem to return the expected data. I have even tried creating a query to just return the array of numbers to feed into the IN/ANY clause. The green helper text shoes as valid SQL but it doesn't execute.

Beyond me other than perhaps having each ID in single quotes though that shouldn't matter....
@victoria SOS

Turns out I have to turn off prepared statements on the resource


Thanks for everything

1 Like