URGENT: Listview not displaying components inside. Please help

I had an app working perfectly for weeks. Today, everything inside my listview component doesn't show. I haven't made any changes for that to happen.

This is the correct behaviour. Somehow just opening the edit mode, it works when I change any value.

This is how it is shown in the published version:

Inside the 2nd list view (the one not showing) there is a form.

Just by selecting the form inside the listview, it renders.

When I de-select it, it hides again.

If you see it selected, the inputs are also hidden, they are supposed to be shown.

It seems that all heights are being set to 0 or something...

I'm also having a major issue with the list view, where everything worked yesterday and today images aren't rendering. In my case the {{ item.values }} are not mapping correctly. :frowning:

1 Like

Hello :wave: I believe this might have been due to an experiment that was turned on this morning.

I just went ahead and turned it off. Could you refresh and confirm that this has corrected your issue?

Hi! Yes!! This solved it, thanks! How can I avoid my apps to be altered by these changes? Is there any way?

Also fixed the issue for me @andoliveyou. Which leads to the same question from me—how might we lock our apps so they're Retool codebase isn't auto-upgraded?

Perhaps we could manage this in the Releases & History menu side of apps. What I imagine being most ideal is the ability to see what Retool release we're on, then toggle between releases in preview mode, then select the Retool release to use when deploying a new release via the Create New Release feature.

Seems that auto-upgrading Retool releases would be logical for any users who aren't using the Releases feature.

At minimum I'm curious if there is any way to subscribe to notifications about when the Retool codebase changes, along with a changelog? This would at least empower us to better notify all the people impacted by unforeseen downtime due to breaking codebase changes.

I'm so sorry you were both affected! We try to make experiments as safe as possible by testing internally and beta testing to mitigate risks like this, but we hadn't received reports about this type of bug previously.

I can definitely share the feedback about not being able to opt into versioning and experiment changes and how it affects Cloud Users!

In the meantime, would you both be comfortable sharing your app's JSON so I can debug what happened locally? It'd be immensely helpful! (You can also DM me!)


I'm having exactly the same issue as we speak - listview container form elements disapper unless they're selected in edit mode, some kind of height malfunction.

Is it possibe to turn the experiment off for our account too please? Thanks

@andoliveyou let me know if I need to DM you or something or you can look up the account from my email

Hi @andreonlovesparkle! Could you DM me your domain name? This experiment is no longer on by default but I can doublecheck for your domain. It would also be helpful to get a JSON export of your app.

Yes, you might be right and it's unrelated to the earlier experiment. It's just the sympoms were very similar.

Did more investigation and the pattern is slight different with my issue. What happens is:

  • create a new form inside a tabbed container
  • in this form create some list view
  • place some form elements (except buttons) inside that list view
  • save / reload the page
  • all elements are gone :slight_smile: (they are present in the code, just has to be clicked on through component drawer menu to become temporary visible)

Funny enough I discovered a remedy after the elements are out, you just write 'false' into their hidden attribute, again save / reload the page and when it's back up all elements are there. Then this 'false' can be removed and elements stay in for good.

Must have something to do with how you optimise performance of listview. Separately (but likely related) noticed that validation (mandatory required) of form elements inside listview has been switched off - you add underscore to the element's required property and overarching form is ignoring it. That's no big deal as I put together a flexible manual validation module, kind of needed it anyway for some custom business rules.

Will DM you soon once I get a spare minute with json and whatnot.

Thanks for your help!