Unable to use Google Analytics


Thank you for the breakdown! I am looking into this with my team, but potentially there could be issues with setting up Google Analytics 4 currently. Are you able to connect to Universal Analytics?

Hi Lauren, any luck with this? I can confirm that I can connect to UA but GA4 is still not working.


Hey there :wave: Unfortunately no updates here, we still recommend using Universal Analytics.

1 Like

I had the same problem even when connecting GA UA.

The data simply doesn't flow to google analytics.

Hi @luizalves ~ could you share some more detail on how Analytics query is set up?

It actually worked. Just took some time to start flowing into GA. Thanks!

1 Like

Hi @lauren.gus, @shawntax, has any progress been made to support the new GA4 API?

Hiya @jgmta ~ we don't have an estimated release date just yet, but our eng team is scoping out the work here this quarter!


any update on GA4? UA is going to be discontinued in less than 2 months so this integration wont be usefully anymore, right?

1 Like

Hi @Lukas, and others following this thread!

this integration wont be usefully anymore, right?

Yes, once Google deprecates UA tokens our existing GA integration will no longer be able to send usage data.

We are aiming to release compatibility with GA4 by May 15, with a release for self-hosted versions at the end of the month.

you guys are awesome :rocket:

Hey @shawntax ! Is the GA4 connector still on track to release this week? I'm really looking forward to getting to work with it.

:wave: @jwilmoth3237, the final stretch of work here got pushed to a cycle ending on May 23, so it's possible this may take another week. Will keep you posted!

1 Like

hey @shawntax - just checking in if this has been postponed? I didn't see any change so far. thanks!

Hi @Lukas and folks in thread,

The self-hosted release notes still need to be updated, but the GA 4 integration is out as part of 2.119.8! In addition, we'll need to enable a feature flag on your instance to see it -- DM me directly to get that ball rolling. This will be available by default without flag in stable release 2.121.

And a note here that this is for the GA integration on self-hosted instances with an Enterprise plan with us (and Cloud orgs that are on the Enterprise plan).

Hi everyone! Just to clear up any potential confusion here:

If you're using Retool Cloud, that means you'd be adding a resource that connects to Google Analytics APIs (docs for that are here), and this is different from the GA4 integration we've just rolled out.

The resource integration on Cloud is currently not included in the GA4 released I've been mentioning. That is a separate stream of work our team will need to do in order to update the resource to be able to handle GA4 properties.

Hi @shawntax ,

I also want to use google analytics to push my app level metrics . Is this issue resolved now . If not any other option which we can use for this

We are currently on self hosted retool version 2.117.11

Hi @shawntax, does this mean we need to switch to self-hosted in order to connect to GA4? Any plans to support this on Cloud?

Hey there @nkeil! At the moment you can connect to GA4 both on self-hosted and Cloud, but only on the Enterprise plan.

If we do make this available to other plans, I'll be sure to update you here!