Unable to load Chained cert

I am trying to start my nginx in production mode but I am seeing
2023/05/29 03:41:27 [warn] 1#1: the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/retool.spendline.ca.ssl.conf:5

cannot load certificate "/var/lib/https-portal/retool.spendline.ca/local/chained.crt": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/var/lib/https-portal/retool.spendline.ca/local/chained.crt','r') error:2006D080:BIO routines:BIO_new_file:no such file)

As I am running in production mode why it is expecting chained crt from https-portal as configured nginx.

Everything is working as expected when I run with https-portal in local mode

Hi @Revanth_Kumar_Mulluri!

It looks like you're now connected to Kenny in a different support thread, but just in case it's helpful for other users, I'll keep this thread up to date.

We asked if custom certificates are being used (as in these instructions https://docs.retool.com/docs/configure-ssl-certificates#add-custom-certificates-manually) and if so, it would be helpful to know how you're mounting the certificates to the container!

I tried first with custom certs and did not work and then tried with https portal now working as expected

Oh fantastic! Very glad to hear it :raised_hands: