Unable to delete transformer

Never had an issue with this before. With one of my modules when I try to delete a transformer nothing happens. From memory I think there used to be a confirmation. Now I neither see the confirmation nor does it delete. I tried deleting both from the bottom panel sidebar and from the 3-dot menu when the transformer is open. No change in behavior when I refresh the page. I haven't spotted any errors in the browser console and I haven't attempted this is in another module or app.

This seems to be the case for components too. If I add a component to my module the only way I'm able to delete it is if I "undo" back to before I added it. Selecting delete does nothing.

Has anybody else experienced this issue?


Hey there :wave: This should be fixed now, are you seeing the same behavior on your end?

This now works again, thanks for the update @lauren.gus

Hello! I'm having the same issue. I can't delete any of my components after upgrading. How was the issue fixed?

Once lauren told me to try again it worked


Hey there :wave: A fix for this bug was shipped, are you still experiencing this behavior?

yes, still no changes on my end

Hey @Gabi.S

Happy to help here! Are you currently deployed on cloud-hosted Retool or on-premise? If on-premise, what version are you currently seeing this in, and are you seeing any errors in the browser console?

On prem- we just upgraded to 2.89.11 and that's when I noticed this issue. No errors that I've seen, just non-responsive when delete is attempted

I see, thanks for flagging this! Our engineers were able to track down the issue and have pushed an update to our on-premise version. Could you try updating to 2.89.13 to see if this resolves the issue?

1 Like