Tables do not show all columns

Hi Retool community,

I'm very new to both Retool and SQL, so I'm sorry if this is straightforward.
I run into an issue where I can query information from a Postgres table, but certain columns are not shown in the Retool table.
In the preview they are show just fine, but in the actual table it is not visible.

My query is just this:

select * from poc.employees;

And my DB table is this:

This is the preview (column names):

But in the table the full_name column is missing:

If I make another table with the same data + query, the 'id' column also disappears and I can only see 'hid' and 'external' columns.

I'd appreciate it greatly if anyone can pinpoint me in the right direction!

Kind regards,

What does this look like when you inspect the table in the right panel?
Screen Shot 2022-03-15 at 4.21.58 PM

Thank you for replying!

It looks like this:

This is the Employees query:

Apparantly I had to toggle these. Not sure how that works though. If I toggle 'full_name' to be invisible, the 'id' column becomes visible in the table. If I toggle 'full_name' again, then it becomes visible as well...


Anyway, happy that it works :slight_smile:

Hi @Metuse :wave:

This sounds like odd behavior. Glad you were able to find a workaround for now but if this problem shows up again you might want to write to us through your Retool instance so we can take a closer look at your app to see what the underlying cause might be and if there's an issue we need to fix on our end!

I'm having a similar issue, however my schema is not refreshing when using the table schema refresh button. I am able to query the columns but when using a transformer these columns do not appear in the table query. I am using an explicate query calling on these columns an not just selecting all.
Running the query

Returned data from query

Transformer error

Hey @daviddcarmona!

Does your query work if you use PROMOTION_DURATION: row.PROMOTION_DURATION instead of just PROMOTION_DURATION?

It looks like you're declaring a number of variables at the top of your transformer allowing you to use some object property shorthand but I'm not seeing a declaration for either PROMOTION_DURATION or PROMOTION_TYPE.

Hey @Kabirdas,

The query works allowing you to see the columns and see them in them if you use the query via a table however I was never able to use them in a transformer or see them in the query state via the debug tool/state. The work around I took was to kill the current connection can re create it, that seems to allow the new columns to appear in the schema tool and be used in transformers.

Ah I misspoke, sorry, I meant does the transformer work if you use PROMOTION_DURATION: row.PROMOTION_DURATION instead. Based on the screenshot I would expect PROMOTIO_DURATION to be undefined in that snippet either way. Is that not the case? Or did you make any other changes to the transformer after posting the screenshot?

As for the schema display, have you tried using the refresh button mentioned here?