Support MongoDB Atlas Serverless

I'm new to retool and trying to connect to my MongoDB atlas database.

When using the connection string:

replace the password
replace the database with database name

I get the error:

Saving failed. Text record must only set authSource or replicaSet

I googled the error but cannot find the answer. I follow the tutorial


Hi @rutgerhofste :wave: thanks for reaching out with this! Based on the instance hostname within the connection string you provided, I think the answer is probably Yes; but just to confirm: is the MongoDB instance that you're connecting to a part of the new MongoDB Atlas Serverless platform?

yep, that's correct

I am getting this same error on the same platform. Though I am self hosting retool.

Got it, thanks for the confirmations/insights @rutgerhofste and @Dax911! I've been able to successfully reproduce this issue – I'm unable to successfully establish a connection to my MongoDB Atlas serverless instance from Retool (version 2.80.2) and observe the same error message. I've filed an internal bug ticket to have this behavior addressed – while we're not in a position to provide a fix timeline quite yet, I'll be sure to provide updates via this thread accordingly :grinning_face_with_smiling_eyes: Please don't hesitate to let us know if you have any other related questions or updates in the meantime too though!


Could you please point when you are going to fix the issue? I want to use a Serverless MongoDB instance in my Retool App, but I can't.


Hey @programmer!

Unfortunately we need to test for and address some potential migration issues before making changes to the underlying SDK, and haven't been able to prioritize this work to support connecting to Mongodb Atlas Serverless yet. It is still in our queue of work to be done and this thread is linked internally, but we don't have an updated timeline at the moment :disappointed:

@alex-w Is there any reasonable workaround for this that you can suggest for now?

Hey @alex-w,

any updates on this? We also are stuck on this issue, currently.

Best regards

Hey @philipp! The SDK update would include some breaking changes for common query patterns in Retool which raises the difficulty of implementing support for Serverless MongoDB. As a result we don't have a timeline on when we'd be able to add in support for Serverless, and will only be able to connect to Dedicated or Shared clusters in the meantime.

We'll keep monitoring this thread and prioritizing that larger scale migration against work on other new resource types and authentication methods. Please chime in here with a +1 if you are coming across this as a blocker getting spun up!

Absolutely running into this blocker! +1 here.

Running atlas is significantly less expensive than running a dedicated node.

Does this mean the integration is supported now?

Hi @hosseink! We currently support Mongo Atlas Clusters but not Mongo Atlas Serverless Instances. We're still hoping to add support for serverless in the future, but have updated the title of that section on our docs to clarify.

That sucks. We cannot use retool without support for serverless instances. Is this still not available? I am getting the same error

Hey @hsyyid! Stepping in here to let you know that we upgraded our Mongo driver to now support Atlas serverless instances. I believe the change is still behind a flag, but I can enable it for your org! Let me know if you're interesting :slight_smile:

Hey Victoria, in the self hosted version its not working. Is there any fix?

Hey @Benedikt! What version of Retool are you currently running?

Running Version: 2.105.7

Got it, thank you! Let me look into this feature's availability

1 Like

Any news? When creating a mongodb serverless resource the following error appears: "Unable to connect. Error: Text record must only set authSource or replicaSet "
but only in the self hosted version of retool