SSO/SAML failing after upgrade - Working fine before

When I read the below post, I thought, hopefully there is something here to help. That was not the case, we already had both the base domain specified and the insecure cookie setting for false.

We have Retool configured with ADFS authenticating against our on-premise active directory. It was only after the upgrade that is began failing.

We get the No AssertionConsumerService error.

No AssertionConsumerService is configured on the relying party trust '' that is a prefix match of the AssertionConsumerService URL....... (I left the URL out since it will probably cause this to get marked as 'SPAM' or a violation of the TOS as it did before. They fixed it a few days later, but I'm looking for help soonest.

I have gone back through and re-validated settings on ADFS. I know the AssertionConsumerService url is set correctly. It was working prior to the upgrade to 3.0.1. I've been fighting with it for a few weeks (hence why we are still on 3.0.1. I did not wish to upgrade it to 3.0.3).

I rolled our sandbox version (A clone of production) back to a prior snapshot and it worked against ADFS again. I re-upgraded it to 3.0.1, and it still fails. Even with making sure BASE DOMAIN and the Insecure Cookie settings are correct.

Looking for any guidance I can get on this.

Hey @summitrad!

Strangely, the only instances I'm seeing of this error were caused by capitalization mismatches in the ACS URL. I'm not sure what happened with the 3.0.1 release that would cause this error.

It might be helpful if you could share screenshots of your SSO configuration from both the Retool and IDP sides for some additional context that might help identify what happened here.