SQL query won't run for second time

The second time the following SQL query is triggered nothing happens:

UPDATE annotate SET annotation_date = NOW(), atext = {{atext.value}} WHERE id = {{current_id.value}}
  • I've tried triggering the query trough code and with the manual buttons 'Preview' and 'Run'. Same result.
  • If {{atext.value}} is changed before triggering it the second time, the query does run.
  • When 'atext' if removed from the query like below, the query does run.
UPDATE annotate SET annotation_date = NOW() WHERE id = {{current_id.value}}

I've tried to make an API call to create a workaround. But in this case I can only run the query by using the 'Preview' button. Clicking on the 'Run' button has no effect, it seems the button doesn't work at all. See animation below:

Using on premise 2.94.9

Hey @Nick!

Does the SQL query work properly if you replace atext with an equivalent component? I'm curious to know if it is also referenced elsewhere. It can be helpful to take a look at the components dependency graph in the left panel by hovering over the graph icon after selecting the component:

Would you also mind sharing the configuration and dependencies of review?