Some columns are not visible

I have a data source connected to my dynamo DB table. When running the query or previewing it in the actual data panel, I can see all the columns.

However, the table I have only shows the first five columns that were originally there when I first set up the table.

Things I've tried:

  • Delete the table and create a new one
  • Clicking regenerate columns
  • Attach a primary column

Nothing is working. I can't see the new columns.

Try clicking the refresh columns button (in pink)

It's not a structured database, you might need to map your data. We have transformers running that map our data properly before putting it into a table

Yes, tried that. The new columns just don't show up.

Can you show me an example of what you mean by map your data?

Hi @Ruchir_Barron! What does your data currently look like? A screenshot of your left panel would be helpful:

left panel > {i} > your_query > data

Does the data show up if you create a new table component and reference the new query?