Slack Integration can't see private channels

  • Goal: Connect ReTool via Slack integration (as a resource) and automatically post notifications to a private channel using a resource query workflow block.

  • Steps: Tried to set up Slack resource, configured resource query block with slack resource to run /chat.postmessage, workflow block cannot find the private channel I added ReTool to. Looked at slack permissions scopes docs, double checked resource oauth scopes in resource config.

  • Details: Cloud hosted. According to slack docs, it should only need channels:read and groups:read to find the private channel.

  • Screenshots:
    image
    No matter what I do I can't seem to get the "Channel" dropdown to list the private channel I'm looking for.

Hi @KevinChu, thank you for flagging this. I was able to reproduce the issue on my end. It is currently possible to use the Slack integration to send a message to a private channel from an App, but not from a Workflow (I tried using the channel ID). I created an internal report for this. We'll update you here when it's fixed. :slightly_smiling_face: