Sheets query works in preview mode only

I'm using the google sheets connector to "append data for sheets", but it only works in Preview mode.

When I run preview mode, it takes 2/3 seconds to execute. Then without changing anything, I run it in "Run" mode and then the query loops forever.

Its a bit sporadic, sometimes it works sometimes it doesn't.
I'm writing ~500 records to sheets, so I don't feel like its a rate limit issue but I'm not sure how to diagnose that further because I don't get error messages.

I tried following this thread SQL query, preview returns data but "Run" returns "404" and cleared my cookies, but that didnt work for me.

Any ideas?

This is the relevant subsection of the script I'm trying to run

stripeCursor.value = ""

//this works
await getInvoiceLineItems.trigger()

// this is a google sheet call that only works when I run in preview mode
await writeRawIRFS.trigger()

stripeCursor.value =[0].stripe_id

okay I just deleted the query and re-wrote it from scratch, and now its working