Selecting tags (Dropdown) in a table resulting in Error 5 in Chrome

We are using the self-hosted version of Retool and I can create a table, populate it, and add additional columns, but when I try changing one of the new columns to a Tag (Dropdown) type, Chrome immediately crashes with an Error 5.

Any advice?

Hey @Magenta_Jackie,
I'm assuming you are using the latest version of Chrome? We haven't had any other reports of browser crashing with Tag (Dropdown). Can you please open a support ticket by writing to us in in-app chat or emailing ? We'll be happy to take a look at your setup, and we can report back to the forum once we troubleshoot what's going on.

Hi magenta_Jackie,
Are you still seeing this error? Are you able to see send a screenshot or recording or maybe the exported JSON app of a demo to reproduce the bug?

Thanks for checking in about this!

Yes, I'll try getting a recording and export the JSON app. Start a ticket with and send it that way, right?

You can actually drop the json and/or mp3 files right here in the chat app or likewise the email option you've said!

Thanks! I just sent an email. Thanks again for being so proactive on supporting this!

Sounds good thanks Magenta_Jackie. And, if we uncover anything in our support chat, we will post them here too! Thanks!

I'm curious if there are any updates on this? My browser also immediately hangs whenever I switch a column type from "Auto" to "Tag (Dropdown)". I'm on Chrome 107.0.5304.110.

I thought it was a lost cause and I just needed to choose a different column type (Tag (Dropdown) column type was crashing Chrome with only 1400 rows of data), but I started a new app and just for the heck of it I tried using Tag (Dropdown) as a column type, and it worked! I'm not sure what the difference was (we performed a Retool security update at some point-- maybe that?). I know it's not a great answer, but maybe the good ol' turn it off and back on again trick will work?

1 Like

Hey there! This is still something that's being worked on but we'll let you know here when a fix has been released!

If you don't need the newer table features for the table that's causing issues with the tag column, you can try using the old version instead:

That has, in some cases, helped significantly with performance.

1 Like