Scroll bar glitch on table with auto height and dynamic row height

I have multiple tables that use auto height as well as dynamic row height. They seem to consistently produce a problem where it keeps flashing the scroll bar when not needed. It seems to happen the most when a change happens to the table (row added or removed). Has anyone experienced this issue and now what is causing it?

The GIF doesn't accurately represent how fast the glitch is happening, it is more of a strobing effect.
Recording #5

I experience this as well at times (typically when I'm dealing with nested listviews of auto heights). Curious as to the best fix.

This is a Mac-specific bug that is caused by the table layout reflowing and changing the height of the rows when the scrollbar appears.

It can be reproduced on Macs when the system preference "Show scroll bars" is not set to "Always". However, it can be a bit tricky because the row contents have to be set in such a way that their height will be affected by the scrollbar appearing.

I can't figure out a fix using the tools available, so I am resorting to a static-height row and using the cell 'tooltip > overlow' add-on.

If Retool were willing to fix, in my case at least, it would be acceptable to override the Mac behavior and force a visible scrollbar when row height is set to dynamic.

1 Like

Thanks for adding these helpful details, @Levi!

I am able to reproduce this issue & have flagged this as a bug to our team. I'll keep you posted when I get an update internally

1 Like

Just to say I experience this in windows as well.

1 Like

I have this bug too in edit and view mode. What should i do or when you will fix it? @Tess

Hi @Vlad_Posibl Thanks for letting us know & sorry to hear! I don't have a timeline yet :disappointed: But I'll check in with the team

For the time being, does it help to use a static-height row or a fixed height table?

with static-height row its help, but i need dynamic row height. i will try with fixed table height, ty

I'm seeing this bug too, in Windows, self-hosted, when using tables within nested list views. (Because some of the lists I'm displaying are extremely long, replacing the innermost nested list with a table improves performance, even compared to the new list view.) I haven't tested enough to confirm that this is the cause, but I'm seeing it primarily in tables with HTML columns. Setting a static row height is a workaround for some tables, but for others, the largest row height is not tall enough. Similarly, setting a fixed table height stops this behaviour but then doesn't allow my tables to display the way I need them to.

I'm still seeing this bug, is there a fix coming?

Thanks!

1 Like

Hi @Ned,

Yes it is in our queue to be fixed, but I don't have an eta yet. I'll post here if I get any updates internally

1 Like