ROLLBACK - Unable to perform operation using terminated connection - Snowflake

I'm having issues with trying to bulk upsert records into Snowflake using the GUI mode.

When I try and run an upsert statement, I get the following error message:


I have read this blog post here , where it seems that the team is aware of the bug and actively fixing it: ROLLBACK - Unable to perform operation using terminated connection - #2 by victoria

The issue I am having is that, rather than doing an insert query, I would like to do an upsert query instead (insert new rows, merge existing rows).

What is the best way to write the javascript to accomplish this? Trying to find other documentation online but have hit a bit of a wall!

Have you made any progress on this? I have the same issue running bulk inserts or upserts into Snowflake. The resource connection is valid, and I'm lost at what to look at.

Hey @mitchscales @Heather, can you share how your Retool instances are hosted and what versions you are on? Unable to reproduce on Retool Cloud, but will dig into your specific instances. Thanks!

Hey @joeBumbaca

My retool instance is hosted on the 'Retool Cloud'.

I'm not sure how I can check the version number? Tried to find something online but couldn't see anything, I would assume I'm on the latest version.

I just tried this again (I had to do a workaround where I essentially create the underlying SQL insert statement using some funky JS instead of using the GUI mode), and it still returns the same issue:

Update: I ultimately found the cause of the error I was experiencing is that Retool wraps all values of the bulk upsert statement in double quotes. This causes the query to fail if a custom column in the table isn't uppercased to match the internal automatic uppercasing that Snowflake performs.

The error message sounds network-y, which lead me down way too many rabbit holes.

@mitchscales All cloud versions are the same, so no worries there! Are you able to check and see if there is a column mismatch like @Heather is describing?