Retool workflow: inserted record does not contain JSON input

Hi there,

I just set up my first workflow in retool :tada:

The flow is simple:

  • I have a trigger based on a retool webhook
  • the JSON in put is to be inserted as a new record in a retool database

Here's the flow:

When I run the workflow, the events are empty in my message_events table. Am I missing something?

The result of the run is

[{"id":8,"created_at":"2023-04-14T11:02:30.539Z","events":{"shop_id":"1","shop_name":"test"}}]

Thanks for all the help :pray:

I realize that even when manually adding a row and providing:

{"shop_id":"1","shop_name":"test"}

for the JSONB input, it still inserts the row with a null value. :thinking:

Hey @phibsi!

Out of curiosity, if you use Object mode for your changeset instead of Key value pairs and pass in the following does it work?

{{
  {
    events: {"shop_id":"1","shop_name":"test"}
  }
}}

Also curious to know if you're seeing this issue when running the individual block or only when running the workflow as a whole.

Hey @Kabirdas,

thanks for following up. Yes I have the same issue even when using the Object mode.

I also tried inserting the JSON directly via the retool db UI: Drive View | Descript - Descript

Any idea what's misconfigured? Everything else is working fine.

Hmm... very odd. On our end, I'm seeing a non-null constraint error involving the template_id column coming from your org:

insert into "input" ("events") values ($1) returning * - null value in column "template_id" of relation "input" violates not-null constraint

I'm not sure that explains the behavior you're seeing in the UI but it may be worth investigating the values you have in that column. Also would be curious to see if any errors or failed requests are showing up in your browser's dev tools when making the UI edit.

image

Dear any weary travellers you have to used the cursed jutsu: stringify to parse

{{JSON.parse(JSON.stringify({ was_overcome: value.objectionOvercame, reason: value.reason, objection_id: value.objection_id }))}}
1 Like