Retool Connector Issue - All connections not working

Surfacing Retool DB issue!

Screenshot 2024-01-31 at 18.25.25


I have the same problem. I think error is on Retools side. Did not see anything on the status page.

Hey All, thanks for the ping. Looking into this now

1 Like

Same issue

Same issue !

Same issue here. Happening on Retool's provided DB, as well as external Postgres DBs hosted on AWS.

Same issue here, but with Postgres so my guess is that it's on Retool side

Flagged to our engineering teams and we have opened an incident internally. Will update everyone here as soon as I have information to share.

I don't think it is limited to the Retool DB. I get this error in all queries in a workflow:

{"data":null,"error":{"message":"Unexpected error occurred while running query","queryExecutionMetadata":{"estimatedResponseSizeBytes":0,"isPreview":false,"resourceType":"restapi"}}}

Doesn't matter if it is a restapi or query to an SQL on Azure. Same error all over.

I'm facing the same issue too. I can't even access the Retool Database tab.

Agreed. I have the issue connecting to my external database using sql server

Same issue here

Same issue here


Seems it's back to normal :pray:


Thanks for the confirmation @stefancvrkotic! This should be resolved now for everyone, let me know if you see otherwise.


Working for me :slight_smile: Thank you !

1 Like

It's working fine now, many thanks!

1 Like


Now I am seeing:

{"data":null,"metadata":{},"error":"Internal Error running a block: Error: An internal server error occurred"}

This is a workflow block which is only writing 1096 records to an Azure SQL table. It was working fine in testing small batches earlier today and 1096 isn't much. All the data is prestaged in the previous block.


I reduced the size of the block by ~200 records and tried again. This time I get:

{"data":null,"metadata":{},"error":"Timeout Error: The block run exceeded the timeout of 10000 ms. This timeout can be increased in the block's 'Settings'."}

So of course I will do that. However the workflow IDE is painfully slow right now. So even making a small change like that involves a lot of these: