Retool App Extremely Slow


From Jan 25th evening pacific time, Retool app has been extremely slow for us to the degree that we can't use it. We didn't change anything though. The issue persists in the past two days and our entire production environment is down because of this issue. So it's kind of urgent.

The experience is that when we open an App in Retool Web editor, the initial loading app takes an extraordinary long time, such as taking 10 minutes to load those queries that are "automatically run when input changes". Normally it would like like 3 seconds. Loading the UI such as the logo also takes like 10 min, normally it should be instant. After it's finally loaded in 10 min, the Editor is barely operable. If I click on a button component, it takes like 2 min to react, and trigger the event it is supposed to trigger. Loading data in the table also like 0.5x speed, columns are showing one by one like a slow-mode movie.

We haven't change anything though. We also went back to 10 released versions, which were all running very smooth and fast in the past, now they are all slow like not working at all. There seems to be something fundamentally broken in the Retool infrastructure. Maybe your container is out of memory???

@mattsun Sorry about the issues, thanks for flagging this. Can you post a link for your retool app and we can further investigate? Or is your organization on premise?

Hey @mattsun, we identified the issue and deploying a hot-fix today for it. Thanks for being patient

1 Like

Hello. I have been facing a similar issue with my dashboard and I have been struggling continuously within the last 4 hours but the dashboard doesn't get loaded. Also, earlier it took only 2 seconds for the dashboard to get loaded but now it takes more than 10 mins to load it and only half pf the queries are running and even after that the page becomes unresponsive again and again. Please help me asap

Hi @Hanee_Rai do I have your permission to step in to your account to take a look? Which app?

Yes, please check it and let me know asap. It's really urgent. I am talking about the amazon sales insights app.

Thanks @Hanee_Rai

I was able to get the app to load by setting the queries to run on success of one another, instead of all at once. I also noticed that query10 & the chart4 component seem to be causing the app to crash. In the support copy I made of your app, you'll notice it loads as long as you don't trigger query10. I hope that info helps to unblock things a bit for the time being! I am checking internally with our engineering team to see how we can resolve the issues with chart4 and the blank page showing on page load.

Hello Tess,

Thanks for the insight but idk I am still not able to load the support copy or even the original app. It just turns my app into an unresponsive page again and again. I would ask you to please remove the query 10 and chart 4 components from the support copy if your engineering team feels that it is the cause of the app crash. Because for now it still shows the same error for me.

Hi @Hanee_Rai Thanks for your patience! I see that my teammate, Lauren, sent over a working copy of the app :slightly_smiling_face:

To summarize, we identified a separate bug in this app that impacts charts, and our team will continue to investigate!